Resolved
Confirmed our registrar has resolved the issue.
Identified
Our domain registrar is currently experiencing a Nameserver Resolution Degraded event, causing intermittent connectivity issues and partial traffic disruption across our services. This is an ongoing incident isolated to registrar's nameserver infrastructure. Our team is actively monitoring the situation and coordinating. Further updates will be provided as the situation develops.